Как сравнить две строки в Excel?

Размещено

Ваш вопрос:

Как сравнить две строки в Excel?

Ответ мастера:

Microsoft Office Excel – это табличный процессор. С его помощью можно сравнивать не только числовые значения, но и, при необходимости, текстовые, так называемые строковые, данные ячеек. Если воспользоваться функциями сравнения, которые встроены в Excel, это все можно сделать. В этом случае выйдут цифровые или логические значения результатов операции. Если же нужно визуальное выделение ячеек таблицы, тогда используются опции условного форматирования.

Если у вас появилась необходимость сравнения текстового значения в ячейках таблицы и образца текста, если вам нужно пересчитать совпадающие значения, тогда вам нужно воспользоваться встроенной функцией сравнения ячеек. Эта функция СЧЕТЕСЛИ. Заполняете колонку текстовым значением. После этого в другой колонке щелкаете по ячейке, где должен быть результат подсчета. Туда нужно ввести определенную формулу. Допустим, значения, которые надо проверить, находятся в колонке А. Результат этого значения должен находиться в первой ячейке колонки С. Формула должна быть следующего содержания: =СЧЕТЕСЛИ(SA:SA;»Виноград»).

Слово «Виноград» мы условно отмечаем строковое значение. Именно с ним мы хотим сравнить значения остальных ячеек колонки А. Можно поступить по-другому. Не указывать строковое значение в формуле, а указать ячейку, в которой оно находится. Пусть это будет ячейка В1. Тогда наша формула будет выглядеть соответственно: =СЧЕТЕСЛИ(SA:SA;B1).

Если у вас появилась необходимость выделить в таблице результаты сравнения строковых переменных визуально, вам нужно использовать опции условного форматирования. Разберем такой пример. В колонке А есть ячейки, в которых текст совпадает с текстом в ячейке В1. И их надо выделить. Прежде всего, нужно выделить эту колонку. Для этого надо щелкнуть по ее заголовку. В меню Excel выбираем закладку «Главная» и находим команду «Стили». Там есть кнопка «Условное форматирование». Нажмите на нее. Теперь находим раздел «Правила выделения ячеек» и нажимаем на строку «Равно». Откроется окошко. Там нужно указать, с какой ячейкой надо сравнить эту колонку, и нажимаем на В1. Выйдет список с вариантом оформления, нужно выбрать нужный и нажать на кнопку ОК.

Читайте также:  Как установить Торрент?

Допустим, вам нужно сравнить с образцом В1 сразу несколько строковых значений. В этом случае, вам надо использовать комбинацию встроенных функций ЕСЛИ и СЦЕПИТЬ. Эти функции работают следующим образом. Первая функция СЦЕПИТЬ соединит в одну строку те значения, которые вы ей указали. Если вы дали ей команду: СЦЕПИТЬ (А1; и В1), то произойдет следующее. Эта функция добавит к строке А1 текст «и» и потом добавит строку В1. Получилась новая строка. Теперь с помощью функции ЕСЛИ, эту строку можно сравнивать с образцом. Если вы собираетесь сравнивать одновременно несколько строк, дайте ячейке-образцу определенное имя. Вы нажимаете мышкой ячейку-образец и слева от строки формул вводите имя. Пусть это будет «Образец». После этого выделяете ячейку, в которой хотите увидеть результат сравнения и вводите следующую формулу: ЕСЛИ(СЦЕПИТЬ) (А1;” и “;B1)=образец;1;0).

Значение, содержащееся в ячейке с формулой, отмечается единицей для положительного результата, а нулем – для отрицательного результата. Теперь нужно эту формулу размножить на все строки таблицы, которые вы хотите сравнить с образцом. Как это сделать? Вам нужно навести курсор на нижний правый угол ячейки. Дождитесь, когда курсор станет в виде черного крестика. Теперь нужно нажать левую кнопку мыши, и, не отпуская ее, тянуть данную ячейку до последней строки, которую надо сравнивать.